Aranym CVS

Petr Stehlik pstehlik at
Thu Apr 10 13:09:04 CEST 2003

On Čt, 2003-04-10 at 10:48, Mark Duckworth wrote:
> seem to have been solved in my testing abscence.  I compiled cvs aranym
> of earlier today and my hostfs became broken.

note that the stable branch is ARANYM_0_8_0_BRANCH. The CVS Head is in
unknown state (for me at least) now.

> recompiled hostfs using cross compiler.  Now accessing hostfs shared
> folder gives me this error on the aranym console:
> OR m8, imm8 - unsupported mode: i[1-6]=7d 14 00 74 44 c6
> Unknown instruction 00147d80!

This is JIT error. I just tried hostfs of the branch version and at
first it crashed but subsequently it worked OK.

There is a problem with JIT, though, since XControl crashes. Thanks for
letting us know.

> pikachu root # aranym

you run aranym under root? Why?

> curious as maybe I am doing something wrong?  I am using something like
> *DOS, hostfs.dos, I:I in my config.sys and using metados rather than
> betados.

This is correct, but it can't work under MiNT (use hostfs.xfs for MiNT)
and you can't execute files off the mapped drives (see BUGS file).


Aranym-user mailing list
Aranym-user at

More information about the cz-bobek-lists-aranym-user mailing list